Skip to main content
EMS Software, LLC

Restricting Users' Mobile App Versions

Starting with the August 2016 release, EMS will ensure that EMS Mobile App is both forwards- and backwards- compatible, so that the mobile app will still function even if users update it on their devices. Alternatively, if you update your API but users do not update their app, functionality remains intact.

You may wish to force users to keep their installations up to date. For example, you may want them to upgrade their EMS Mobile App after you upgrade the API, or you may want to prevent them from updating their EMS Mobile App until you upgrade the API. To enforce these restrictions, follow the steps below.

  1. Log in to the API admin page (previously configured here).
  2. Click on Admin tab, and set the minimum and maximum app versions:

Determining EMS Mobile API and Mobile App Version Compatibility

Use the matrix below to determine how you want to enforce user updates.

EMS Release #

Mobile App Version Shipped

Mobile API Version

Mobile App Minimum Version

Mobile App Maximum Version

V44.1

44.1.241

44.1.129

44.1.238

44.1.241

V44.1 Update 1

44.1.288

44.1.146

44.1.288

44.1.288

V44.1 Update 2

44.1.319

44.1.158

44.1.288

44.1.319

V44.1 Update 3

44.1.410

44.1.172.0

44.1.288

44.1.410

V44.1 Update 4

44.1.430

44.1.187.0

44.1.288

44.1.430

V44.1 Update 5

NA

NA

NA

NA

V44.1 Update 6

44.1.477

44.1.208.0

44.1.288

44.1.477

V44.1 Update 7

44.1.487

44.1.249.0

44.1.288

44.1.487

Concept: The Minimum App Version means that users running EMS Mobile App below the minimum will not be able to use EMS. Increasing this value essentially forces users on an older version to upgrade. Maximum App Version prevents users from using EMS Mobile App if they run a version above the max.