Skip to main content
EMS Software, LLC

Plan a Meeting Requirements

  • EMS/Virtual EMS Installed

EMS must be installed and operational.

  • Valid PAM License

You must be licensed for EMS, Virtual EMS, and PAM in order to configure and use this module. If you are unsure if your organization is licensed for PAM, or if you would like to learn more about it, please contact your Account Executive.

Web Application Requirements

Supported Desktop Browsers
Internet Explorer 8, 9, 10, 11
Firefox*  
Google Chrome*
Safari (Mac OS only)

*Latest versions
Supported Mobile Browsers
Google Chrome (Android, iOS 8 and 9)
Safari (iOS 8 and 9)
Minimum System Requirements
Processor: 2.0GHz or faster*
Memory: 2GB or more*
Video: SVGA 1024x768 or higher resolution
Network Card: 10 / 100 / 1000Mbps ethernet (or other Internet connectivity)

Important:  Plan-a-Meeting configuration issues often relate to access rights with this account. Please ensure that the account has the necessary permissions.

Web Server Requirements

Supported Platforms
Windows 2012 Server,
Windows 2012 Server R2
Windows 2008 Server R2
Minimum System Requirements
Processor: 2.0GHz and 4 cores or faster
Memory: 8GB or more*
Hard-Disk Space: 1GB or more
*For up to 100 concurrent users. Increased specs required for 100+ concurrent users.
Software Module .NET Version IIS App Pool
Desktop Web Deploy 4.5.2 4.0
Virtual EMS 3.5 2.0
Kiosk 3.5 2.0
Glance 4.6.1 4.0
Glance API 4.6.1 4.0
EMS API 3.5 2.0
Campus Web Service 3.5 2.0
Campus Planning Interface 3.5 2.0
Floor Plan Configuration 3.5 2.0
Room Diagramming Service 3.5 2.0
PAM Web Service 3.5 2.0